WSL 全称为 Windows Subsystem for Linux,是一个为在 Windows 10 上能够原生运行 Linux 二进制可执行文件(ELF格式)的兼容层, PHPStorm 就不用多说了,作为 PHPer 肯定都用过。

那么,我们日常情况下可能使用过 虚拟机,比如 Homestead ,或者 Docker ,那么这两种方式,在 PHPStorm 中可以非常容易配置 Remote Interpreter。而使用 WSL 就并不是很容易了,我们以前的 PHPStorm 是不支持的。需要使用 EAP 版本。

好了 ,废话不说了,直接看操作。

所需环境(软件)

  • WSL(须安装 Linux 发行版,且安装好 PHP 环境)
  • PHPStorm 2019.3 EAP

PhpStorm 2019.3 EAP 如何安装?

安装 Toolbox App

file 安装完 Toolbox 运行,之后你原本安装的 PHPStorm 会提示你升级,点击 Update 就会更新下载 EAP 版本(原来的版本不会删除)

之后打开 PHPStorm 点击 上方菜单 File | Settings | Languages & Frameworks | PHP 下添加 CLI 解释器。

file

然后选择 Cli Interpreter

file

之后就可以配置 WSL 环境了

file

出现以下内容那就说明配置成功 ,点击 Apply ->OK

file

Hyperf 调试快捷启动

点击 PHPStorm 上方菜单 Run | Edit Configurations 右上角 + 号,添加 PHP Scrpt 文件

file

运行,点击 三角箭头,或者快捷键 Shift + F10

file

之后命令行就可以输出启动信息了。

file

1个回复
1

已经不需要了,忽略 EAP 版本 ,PHPStorm 已经正式发布 2019.3 的版本,已经支持 WSL 了,直接更新即可

0 / 180
网站公告

LaravelCode 正式上线啦

--->>>体验新站

今日诗词
正在加载今日诗词....
标签云
PHP Laravel API 随想 Node.js Linux Yii2.0 Redis 队列 JavaScript Vue Java MySQL 微信小程序 Python Hyperf 转载